Files from build dir end up in install log (Bug #16)


Added by Remko van der Vossen over 3 years ago. Updated over 2 years ago.


Status:Closed Start date:07/13/2011
Priority:Normal Due date:
Assignee:- % Done:

100%

Category:-
Target version:-

Description

When /usr/src is a symlink to another location (on another mount, but I don't know if that's relevant) files from the spell's build directory and staging directory end up in the spell's install log. Problem can be seen with many different spells, bash for example exhibits the problem.

Using:
sorcery 1.14.5
castfs 0.6.1
stable grimoire 0.57-0

When the install is staged the target directory of the /usr/src symlink ends up in $STAGE_DIRECTORY/TRANSL, along with several files within that directory, including $STAGE_DIRECTORY itself when gather_docs is enabled.

This problem causes cleanse --fix to trip over itself because it finds missing files for many spells.


Associated revisions

Revision 2fce1b7b
Added by Jaka Kranjc about 3 years ago

libtrack: detect symlinks in real_invoke_stage_root, fixes #16

History

Updated by Jaka Kranjc about 3 years ago

I can reproduce it (set BUILD_DIRECTORY to a symlink), but luckily only the install log is polluted. The files are gone, which is also seen by tar erroring out when creating the cache.

Updated by Anonymous about 3 years ago

  • % Done changed from 0 to 100
  • Status changed from New to Resolved

Updated by Jaka Kranjc over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF