[COLLATERAL] diffutils("cmp") (Bug #186)


Added by Jeremy Sutherland almost 4 years ago. Updated 8 months ago.


Status:Closed Start date:09/10/2011
Priority:Immediate Due date:
Assignee:Eric Sandall % Done:

100%

Category:Devel
Target version:0.63 Estimated time:2.00 hours
Grimoire:Test

Description

This was also affected by the "libsigsegv" package update removing the /usr/lib/libsigsegv.so*
files from being installed

diffutils needs a trigger to re-cast when libsigsegv is changed


Issue hierarchy

Bug #185: [INSTALL:fail] gawk - SHOWSTOPPERClosedEric Sandall

Bug #186: [COLLATERAL] diffutils("cmp")ClosedEric Sandall


Related issues

related to Grimoire - Bug #187: [COLLATERAL] m4 Closed 09/10/2011

Associated revisions

Revision bef800a3
Added by Eric Sandall 8 months ago

Fixes Bug #185, Bug #186, and Bug #187

libsigsegv: Trigger dependent spells on upgrade
diffutils, gawk, m4: Optionally depend on libsigsegv

History

Updated by Eric Sandall 8 months ago

I have m4 and diffutils both installed and working fine without libsigsegv.
$ gaze version m4 diffutils libsigsegv
Grimoire Section Spell Grimoire Version Installed Version
-------- ------- ----- ---------------- -----------------
test devel m4 1.4.17 1.4.17
test devel diffutils 3.3 3.3
test libs libsigsegv 2.10 -

Looks like they, and likely other packages, are missing optional dependencies (with UP_TRIGGERS) on libsigsegv.
$ gaze compile m4
...
checking for libsigsegv... no, consider installing GNU libsigsegv
...

Updated by Eric Sandall 8 months ago

  • Grimoire set to Test
  • Assignee set to Eric Sandall
  • Category set to Devel

Updated by Eric Sandall 8 months ago

Fixed with commit bef800a38d6842e42a9e81af1cf8ba83bc08211f in test.

  • Estimated time set to 1.00
  • Target version set to 0.63
  • % Done changed from 30 to 100
  • Status changed from In Progress to Resolved

Updated by Eric Sandall 8 months ago

  • Estimated time changed from 1.00 to 2.00
  • Status changed from Resolved to Closed

Also available in: Atom PDF