sorcery doesn't see new values in sub_depends when subdepends change (Bug #337)


Added by Vlad Glagolev almost 3 years ago. Updated almost 3 years ago.


Status:New Start date:12/21/2011
Priority:Normal Due date:
Assignee:Jaka Kranjc % Done:

0%

Category:libs
Target version:1.15.x

Description

I've found that bug on 2011-12-20 when added 3.13.x branch for nss spell.

As you may know, all gecko stuff uses it, and some branches are incompatible. To make sure everything will go fine, I added another branch for fresh SeaMonkey.

Situation:
  • nss spell (3.12.11) is installed and has only 3.12.x branch in SUB_DEPENDS
  • seamonkey spell (2.6) is installed and requires nss with 3.12.x subdependency
  • /var/state/sorcery/sub_depends contains this line: "seamonkey:nss:3.12.x"
What comes next:
  • updates via ``scribe update" go to /var/lib/sorcery/codex
  • sorcery -q detects spell version update for seamonkey (=> 2.6), and doesn't detect version update for nss spell (=> 3.13.1), cause you're on 3.12.x branch atm
  • SUB_DEPENDS file for nss spell now has additional subdependency with is used by seamonkey 2.6: 3.13.x

Finally:
A) when you do ``cast --queue'' or just ``cast -c seamonkey'' everything goes fine:

nss preparing environment...
[[ Which branch of nss do you want to build? -> '3.12' ]]
nss running configuration...
[[ Do you want to enable nss for PEM certs? -> n ]]
nss checking dependencies...
nss has a dependency on nspr
nss has a dependency on perl
nss has a dependency on sqlite
nss has a dependency on zip
nss checking for reverse triggers...
3.13.x release needed, forcing it.
sqlite No work to do.
perl No work to do.
zip No work to do.
zlib No work to do.
libxt No work to do.
libffi No work to do.
libevent No work to do.
pango No work to do.
dbus-glib No work to do.
libnotify No work to do.
yasm No work to do.
alsa-lib No work to do.
Collating dependencies...
Spells are to be cast:
---------------------------
nss            seamonkey

Do you want to cast these spells? [y] n
Ok, quitting cast. Figure out what you want.

Spells that have been dropped:
------------------------------
nss        seamonkey

B) but! when you try to ``cast -r nss'' (without touching seamonkey) and select 3.13.x branch, then it's triggered to force 3.12.x branch anyway by line "seamonkey:nss:3.12.x" in /var/state/sorcery/sub_depends, since installed seamonkey (2.5) requires it, which is obviously, wrong:

# cast -r nss
Computing previously installed dependencies...
nss preparing environment...
Which branch of nss do you want to build?
    (0)  DEFAULT
    (1)  3.11
    (2)  3.12
    (3)  3.13

Which one do you want? [3] 

nss running configuration...
Do you want to enable nss for PEM certs? [n] 

nss checking dependencies...
nss has a dependency on nspr
nss has a dependency on perl
nss has a dependency on sqlite
nss has a dependency on zip
nss checking for reverse triggers...
3.12.x release needed, forcing it.
nspr No work to do.
perl No work to do.
sqlite No work to do.
zip No work to do.
Collating dependencies...
Spells are to be cast:
---------------------------
nss

Do you want to cast these spells? [y] n
Ok, quitting cast. Figure out what you want.

Spells that have been dropped:
------------------------------
nss

superdebug log of B) attached.


nss-multi.log.gz (10.7 kB) Vlad Glagolev, 12/21/2011 10:21 am


History

Updated by Vlad Glagolev almost 3 years ago

seamonkey spell (2.6) is installed and requires nss with 3.12.x subdependency

typo

of course it's: seamonkey spell (2.5) is installed and requires nss with 3.12.x subdependency

Also available in: Atom PDF