sorcery 1.15.1 fails to unpack xz-compressed tarballs (Bug #347)


Added by Florian Franzmann about 2 years ago. Updated over 1 year ago.


Status:Closed Start date:02/03/2012
Priority:Low Due date:
Assignee:- % Done:

100%

Category:-
Target version:-

Description

how to reproduce:

install sourcemage from the x86_64 iso, try to cast rtmpdump 2.4.
the result is an empty source directory in /usr/src/rtmpdump-2.4.

tar version is 1.26
xz-utils version is 5.0.3


Related issues

related to Grimoire - Bug #356: glib2 cast failure Closed 02/10/2012

Associated revisions

Revision e5c9b04c
Added by Jaka Kranjc almost 2 years ago

libunpack, libmisc: also detect old style xz archives #347

fixes #347

Revision 058dd796
Added by Jaka Kranjc over 1 year ago

libunpack, libmisc: also detect old style xz archives #347

fixes #347

History

Updated by Jaka Kranjc almost 2 years ago

Works for me.

Downloaded source file rtmpdump-2.4.tar.xz
Waiting for any Solo casts to complete...
Waiting for any other casts of rtmpdump to complete... done.
Staging enabled
castfs: checking sanity of <mnt-dir> and <stage-dir>
castfs: stagedir is okay!
Preparing rtmpdump
Hash checking source file rtmpdump-2.4.tar.xz...
gpg: WARNING: unsafe ownership on configuration file `/root/.gnupg/gpg.conf'
Algorithm used: sha512

Allowing new hash sha512
Checking spell level WORKS_FOR_ME
Spell level is a new allowed level
Hash verification succeeded
Unpacking source file rtmpdump-2.4.tar.xz for spell rtmpdump.
Building rtmpdump

  • Priority changed from High to Low
  • Status changed from New to Feedback

Updated by Anonymous almost 2 years ago

  • % Done changed from 0 to 100
  • Status changed from Feedback to Resolved

Updated by Anonymous over 1 year ago

Updated by Jaka Kranjc over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF