Bug #349

nvidia_legacy_96xx is not compatible with xorg-server 1.8.1 in stable

Added by Carlo Dormeletti almost 4 years ago. Updated over 3 years ago.

Status:ClosedStart date:02/05/2012
Priority:NormalDue date:
Assignee:-% Done:


Category:z-rejected grimoire
Target version:-


See the warning in /var/log/Xorg.0.log

"(WW) NVIDIA: This server has an unsupported input driver ABI version (have 9.0, need < 8.0). The driver will continue to load, but may behave strangely."


#1 Updated by Carlo Dormeletti almost 4 years ago

nvidia_legacy_96xx install version the nvidia driver 96.43.16.

manually installing nvidia driver 96.43.20 (latest) from the site solve the warning, but still some problem in getting 3D acceleration.

#2 Updated by Carlo Dormeletti almost 4 years ago

3d acceleration solved, manually tweaking DETAILS file and modify from 96.43.16 to 96.43.20 worked for me, recasting mesalib with only dri and swrast enabled and recast nvidia (after the modification version 96.43.20), putting Module section in xorg.conf as stated in NVIDIA-GLX documentation dolved the 3D acceleration problem.

#3 Updated by Vlad Glagolev almost 4 years ago

  • Grimoire changed from Stable to Z-Rejected
  • Status changed from New to In Progress

could you make a unified patch against current nvidia_legacy_96xx in z-rejected?

then we will commit the change ASAP to our grimoire.

#4 Updated by Carlo Dormeletti almost 4 years ago

The only modifications is in DETAILS modified VERSION=96.43.20
I didn't know how to modify the SOURCE_HASH= line so i answer n to the abort request due to the has verification.

The other note on mesalib might be appropriate to put in a wiki page about nvidia on Sourcemage but they were told me on IRC #SourceMage, if i remember well by Stealth

#5 Updated by Vlad Glagolev almost 4 years ago

  • % Done changed from 0 to 100
  • Category set to z-rejected grimoire
  • Status changed from In Progress to Resolved

oh, so it's only about version? fine

it must be fixed in z-rejected with ( commit:09f7daff99149e73051b6101aeafe1de7a0305d5 ) and updated on our mirrors in 6 hours.

I'm marking this bug as resolved then.

#6 Updated by Carlo Dormeletti almost 4 years ago

Ok, i'm feeling little useful and not a boring host in IRC

#7 Updated by Vlad Glagolev over 3 years ago

  • Status changed from Resolved to Closed

closing the bug

Also available in: Atom PDF