firefox 10 requires nss 3.13 (Bug #367)

Added by Eric Sandall about 3 years ago. Updated about 1 year ago.

Status:Closed Start date:03/01/2012
Priority:Normal Due date:
Assignee:- % Done:


Target version:0.60


firefox 10.0.2 requires nss 3.13+, but our grimoire only has 3.12

$ sorcery -v

$ cat /var/lib/sorcery/codex/test/VERSION

$ gaze version nss firefox
Grimoire Section Spell Grimoire Version Installed Version
-------- ------- ----- ---------------- -----------------
test crypto nss 3.12.11 3.12.11
test http firefox 10.0.2 10.0.2

$ gaze DEPENDS firefox | grep nss
depends -sub "3.13.x" nss &&

  1. cast firefox
    firefox requests nss with 3.13.x
    nss No work to do.
    checking for nss-config... /usr/bin/nss-config
    checking for NSS - version >= 3.13.1... no
    configure: error: you don't have NSS installed or your version is too old
    • Fix above errors and then restart with "/usr/bin/make -f clien build"
      make2: * [configure] Error 1
      make2: Leaving directory `/usr/src/firefox-10.0.2/mozilla-release'
      [/usr/src/firefox-10.0.2/mozilla-release/firefox-build/Makefile] Error 2
      make1: Leaving directory `/usr/src/firefox-10.0.2/mozilla-release'
      make: *
      * [build] Error 2


Updated by Eric Sandall about 3 years ago

nss has even been recast, but still stores 3.12 as NSS_BRANCH:
$ cat /etc/sorcery/local/depends/nss.p

Updated by Eric Sandall about 3 years ago

  1. cast nss
    nss checking for reverse triggers...
    3.13.x release needed, forcing it.
    3.12.x release needed, forcing it.

Something else seems to be forcing 3.12.x

$ gaze depends nss 1
evolution-data-server depends on nss (optional)
evolution depends on nss (optional)
firefox depends on nss (required)
flash depends on nss (required)
google-chrome-bin depends on nss (required)
pidgin depends on nss (optional)
thunderbird depends on nss (required)
xulrunner depends on nss (required)

$ for i in $(gaze depends --fast nss 1); do echo $i; gaze DEPENDS $i | grep nss ; done
optional_depends nss \
"--enable-nss=yes --enable-smime \
--with-nss-includes=/usr/include/nss \
--with-nss-libs=/usr/lib" \
"--enable-nss=no --disable-smime" \
optional_depends "nss" \
--with-nss-includes=/usr/include/nss \
--with-nss-libs=/usr/lib" \
"to use Mozlla libnss for SSL and SMIME support" &&
depends -sub "3.13.x" nss &&
depends nss
depends nss &&
optional_depends nss \
"--enable-nss=yes" \
"--enable-nss=no" \
"an alternative to nss for MSN protocol SSL support" &&
depends nss '--with-system-nss' &&
depends -sub "3.12.x" nss &&

xulrunner it is.

Updated by Eric Sandall about 3 years ago

Hrm, can't edit the original bug report, but it is incorrect in that our test branch only has nss 3.12.x, it also provides 3.11.x and 3.13.x via SUB_DEPENDS.

Updated by Vlad Glagolev almost 3 years ago

is it fine now in test?

Updated by Eric Sandall almost 3 years ago

No, having xulrunner still breaks firefox and firefox still breaks xulrunner.

firefox forces nss 3.13
xulrunner forces nss 3.12

Having one breaks the other, whomever wins the nss sub_depends race.

Vlad mentioned on IRC that maybe we can try xulrunner with nss 3.13, which I haven't. The sub-depends on nss 3.12 may be from the nss 3.11/3.12 branching and xulrunner just needs 3.12+.

Updated by Sukneet Basuta almost 3 years ago

Is there any specific reason why we don't update xulrunner to the same version as firefox? They should have the same dependencies then.

I tried building xulrunner on my box with nss 3.13, but it doesn't seem to build. nsBaseHashtable.h is the file that fails to build. I'm not sure if nss is the cause however, since I haven't tried building it with nss 3.12.

Updated by Remko van der Vossen about 1 year ago

Firefox has been updated long ago

  • Status changed from New to Closed

Also available in: Atom PDF