openssh LPK patch broken (Bug #404)


Added by David Kowis about 2 years ago. Updated over 1 year ago.


Status:Closed Start date:06/24/2012
Priority:High Due date:
Assignee:- % Done:

100%

Category:-
Target version:-
Grimoire:Stable

Description

A patch fails to apply in stable grimoire for openssh

yes "" | cast -c openssh
Computing previously installed dependencies...
openssh preparing environment...
openssh running configuration...
[[ Apply openssh-lpk patch (LDAP support)? -> y ]]
Would you like to install the init and/or xinetd script for sshd?
        (0)  neither
        (1)  init
        (2)  xinetd
        (3)  both

Which one do you want? [1] 
Enable init script sshd? [y] 
openssh checking dependencies...
openssh has a dependency on e2fsprogs
openssh has a dependency on gnupg
openssh has a dependency on openssl
openssh has a dependency on smgl-fhs
openssh has a dependency on zlib
openssh has an enabled optional dependency on tcp_wrappers
openssh has an enabled optional dependency on linux-pam
openssh has a disabled optional dependency on krb5
openssh has a disabled optional dependency on xauth
openssh has a dependency on autoconf
openssh has an enabled optional dependency on openldap
openssh checking for reverse triggers...
e2fsprogs No work to do.
gnupg No work to do.
openssl No work to do.
smgl-fhs No work to do.
zlib No work to do.
tcp_wrappers No work to do.
linux-pam No work to do.
autoconf No work to do.
openldap No work to do.
Collating dependencies...
Spells are to be cast:
---------------------------
openssh

Do you want to cast these spells? [y] 

Found source file /var/spool/sorcery/openssh-6.0p1.tar.gz for spell openssh in /var/spool/sorcery
Found source file /var/spool/sorcery/openssh-6.0p1.tar.gz.asc for spell openssh in /var/spool/sorcery
Waiting for any Solo casts to complete... 
Waiting for any other casts of openssh to complete... done.
Staging disabled
Preparing openssh
GPG checking source file openssh-6.0p1.tar.gz...
Algorithm used: sha1
Allowing new hash sha1
Checking spell level UPSTREAM_KEY
Spell level is a new allowed level
gpg signature verified!
Unpacking source file openssh-6.0p1.tar.gz for spell openssh.
patching file auth2-pubkey.c
Hunk #2 succeeded at 270 (offset 1 line).
patching file auth-rsa.c
patching file config.h.in
Hunk #1 FAILED at 596.
1 out of 1 hunk FAILED -- saving rejects to file config.h.in.rej
patching file configure.ac
Hunk #1 succeeded at 1511 (offset 90 lines).
Hunk #2 succeeded at 4372 (offset 106 lines).
patching file ldapauth.c
patching file ldapauth.h
patching file lpk-user-example.txt
patching file Makefile.in
Hunk #1 FAILED at 90.
1 out of 1 hunk FAILED -- saving rejects to file Makefile.in.rej
patching file openssh-lpk_openldap.schema
patching file openssh-lpk_sun.schema
patching file README.lpk
patching file servconf.c
patching file servconf.h
patching file sshd.c
Hunk #2 succeeded at 1572 (offset 4 lines).
patching file sshd_config
patching file sshd_config.5
patching file version.h
Hunk #1 succeeded at 3 with fuzz 1.

Spells that encountered problems:
---------------------------------
openssh (pre_build)


Associated revisions

Revision a2403d04
Added by Sukneet Basuta about 2 years ago

openssh: updated LPK patch to 6.0p1 (fixes #404)

Revision de1bbdee
Added by Sukneet Basuta about 2 years ago

openssh: updated LPK patch to 6.0p1 (fixes #404)
(cherry picked from commit a2403d047dbefc9264417b313875767399c20a26)

History

Updated by Sukneet Basuta about 2 years ago

  • % Done changed from 0 to 100
  • Status changed from New to Resolved

Updated by Vlad Glagolev over 1 year ago

Closing the bug.

  • Status changed from Resolved to Closed

Also available in: Atom PDF