cast -O and -R are dreadfully slow (Support #415)


Added by Tommy Boatman over 1 year ago. Updated over 1 year ago.


Status:Closed Start date:07/21/2012
Priority:Low Due date:
Assignee:- % Done:

0%

Category:apps
Target version:-

Description

I'm not certain whether this is a bug or expected behavior, but it is a bit disturbing. All I am trying to do is have Sorcery recast spells that optionally depend on mono so I can fold them against mono. In the time this command has run, I could have brute-force rebuilt nearly 2/3 of the installed spells.

If I am understanding the command structure and executing it correctly, we have either an algorithm issue or (unlikely) an inherent limitation in shell-scripting. In any case, it shouldn't be happening. I'm not familiar/comfortable enough with Sorcery internals (yet), but am more than willing to help diagnose and provide any further information. I'll attempt to duplicate this week on the KVM farm and, until I can duplicate on other systems, I will list as "support" rather than "bug".

Command is: cast -O ask-yes -R mono Sorcery gurus - is this even the right command? If not, let's close this as PEBKAC (problem exists between keyboard and chair), and I'll see what I can do about updating the context help and man pages.

Processes:

16870 pts/2 SN+ 0:49 bash /tmp/sorcery/cast/16870/casting.safe -O ask-yes -R mono
28980 pts/2 SN+ 40:32 bash /tmp/sorcery/cast/16870/casting.safe -O ask-yes -R mono
28981 pts/2 RN+ 35:06 bash /tmp/sorcery/cast/16870/casting.safe -O ask-yes -R mono

Other activity on system: None except for glances
System load/resources: Not an issue (i7 + 32GB)

gaze installed (fonts/xprotos removed since it's rather large and they're irrelevant):

elvis:20090531203834:installed:2.2_0
sysfsutils:20090531204538:installed:2.1.0
openssh:20120721:installed:6.0p1
basesystem:20120721:installed:0.9.5
gettext:20120721:installed:0.18.1.1
libusb-compat:20120721:installed:0.1.4
fontconfig:20120721:installed:2.9.0
gcc:20120721:installed:4.6.3
g++:20120721:installed:4.6.1
tzdata:20120721:installed:2012d
e2fsprogs:20120721:installed:1.42.4
util-linux:20120721:installed:2.21.2
gnupg:20120721:installed:1.4.12
readline:20120721:installed:6.2
openssl:20120721:installed:0.9.8x
groff:20120721:installed:1.21
lshw:20120721:installed:B.02.15
guile:20120721:installed:2.0.5
gnutls:20120721:installed:2.12.20
lynx:20120721:installed:2.8.7rel.2
unzip:20120721:installed:6.0
db:20120721:installed:5.2.36
sqlite:20120721:installed:3.7.13
gawk:20120721:installed:4.0.1
libtool:20120721:installed:2.4.2
libxau:20120721:installed:1.0.6
libxdmcp:20120721:installed:1.1.0
icu:20120721:installed:4.8.1.1
libxml2:20120721:installed:2.8.0
xcb-proto:20120721:installed:1.6
texinfo:20120721:installed:4.13a
m4:20120721:installed:1.4.16
libgcrypt:20120721:installed:1.5.0
libxslt:20120721:installed:1.1.26
bison:20120721:installed:2.5.1
flex:20120721:installed:2.5.35
simpleinit-msb:20120721:installed:1.3
gperf:20120721:installed:3.0.4
libusb:20120721:installed:1.0.9
usbutils:20120721:installed:006
ca-certificates:20120721:installed:20120212
wget:20120721:installed:1.13.4
which:20120721:installed:2.20
smgl-archspecs:20120721:installed:0.8.3
libsepol:20120721:installed:1.16.1
glibc:20120721:installed:2.13
pciutils:20120721:installed:3.1.10
attr:20120721:installed:2.4.46
acl:20120721:installed:2.2.51
libice:20120721:installed:1.0.7
libsm:20120721:installed:1.2.0
docbook-dtd:20120721:installed:4.5
docbook-xsl:20120721:installed:1.77.1
xmlto:20120721:installed:0.0.25
bash-completion:20120721:installed:2.0
rarian:20120721:installed:0.8.1
gnome-doc-utils:20120721:installed:0.20.10
sgml-common:20120721:installed:0.6.3
docbook-sgml-dtd:20120721:installed:4.5
gtk-doc:20120721:installed:1.18
cracklib:20120721:installed:2.8.18
opensp:20120721:installed:1.5.2
texlive-texmf:20120721:installed:20110705
ed:20120721:installed:1.6
libselinux:20120721:installed:2.1.9
t1utils:20120721:installed:1.34
dialog:20120721:installed:1.1-20120706
lua51:20120721:installed:5.1.4
sgmlspm:20120721:installed:1.03ii
libtasn1:20120721:installed:2.12
lzo:20120721:installed:2.06
libcfg+:20120721:installed:0.6.2
gmp:20120721:installed:5.0.5
libunistring:20120721:installed:0.9.3
libatomic_ops:20120721:installed:7.2
libgc:20120721:installed:7.2
pcre:20120721:installed:8.31
metalog:20120721:installed:2
mkfontdir:20120721:installed:1.0.6
libfs:20120721:installed:1.0.3
libfontenc:20120721:installed:1.1.0
pixman:20120721:installed:0.22.2
libdrm:20120721:installed:2.4.26
lndir:20120721:installed:1.0.2
makedepend:20120721:installed:1.0.3
talloc:20120721:installed:2.0.7
lsb-release:20120721:installed:1.4
libexif:20120721:installed:0.6.21
patch:20120721:installed:2.6.1
cpio:20120721:installed:2.11
alsa-lib:20120721:installed:1.0.25
liboil:20120721:installed:0.3.17
libogg:20120721:installed:1.3.0
libvorbis:20120721:installed:1.3.3
libxml:20120721:installed:1.8.17
libmikmod:20120721:installed:3.2.0-beta2
nasm:20120721:installed:2.10
id3lib:20120721:installed:3.8.3
speex:20120721:installed:1.2rc1
json-c:20120721:installed:0.9
fftw:20120721:installed:3.3.2
libidl:20120721:installed:0.8.14
orbit2:20120721:installed:2.14.19
pycrypto:20120721:installed:2.6
distribute:20120721:installed:0.6.27
pyopenssl:20120721:installed:0.13
zopeinterface:20120721:installed:3.8.0
twisted:20120721:installed:12.0.0
libasyncns:20120721:installed:0.8
tcp_wrappers:20120721:installed:7.6
nspr:20120721:installed:4.9.1
nss:20120721:installed:3.12.11
libstatgrab:20120721:installed:0.17
pystatgrab:20120721:installed:0.5
glances:20120721:installed:1.4
ruby-1.9:20120721:installed:1.9.3-p194
slang:20120721:installed:2.2.4
aalib:20120721:installed:1.4rc5
libgii:20120721:installed:1.0.1
libggi:20120721:installed:2.2.1
desktop-file-utils:20120721:installed:0.20
gnome-mime-data2:20120721:installed:2.18.0
shared-mime-info:20120721:installed:1.0
cmake:20120721:installed:2.8.8
ispell:20120721:installed:3.3.02
aspell:20120721:installed:0.60.6.1
hspell:20120721:installed:1.2
enchant:20120721:installed:1.6.0
pyxml:20120721:installed:0.8.4
orc:20120721:installed:0.4.16
libvisual:20120721:installed:0.4.0
vala:20120721:installed:0.16.1
portmap:20120721:installed:6.0
fam:20120721:installed:2.7.0
tdb:20120721:installed:1.2.10
diffutils:20120721:installed:3.2
mpfr:20120721:installed:3.1.1
libmpc:20120721:installed:0.9
binutils:20120721:installed:2.22
file:20120721:installed:5.11
findutils:20120721:installed:4.4.2
grep:20120721:installed:2.10
gzip:20120721:installed:1.5
iana-etc:20120721:installed:2.30
run-parts:20120721:installed:3.4.4
dhcpcd:20120721:installed:5.5.6
tar:20120721:installed:1.26
installwatch:20120721:installed:2010-12-12
locale:20120721:installed:0.0.2
make:20120721:installed:3.82
module-init-tools:20120721:installed:3.16
kbd:20120721:installed:1.15.3
libevent:20120721:installed:2.0.19
sed:20120721:installed:4.2.1
ccache:20120721:installed:3.1.7
bin86:20120721:installed:0.16.18
sharutils:20120721:installed:4.11.1
lilo:20120721:installed:23.2
sorcery-pubkeys:20120721:installed:1.6.6
lcms2:20120721:installed:2.3
lcms:20120721:installed:1.19
libxfont:20120721:installed:1.4.3
libdaemon:20120721:installed:0.14
openslp:20120721:installed:1.2.1
libmng:20120721:installed:1.0.10
libsigc++3:20120721:installed:2.2.10
glibmm:20120721:installed:2.30.1
detex:20120721:installed:2.8
dvi2tty:20120721:installed:5.3.1
lacheck:20120721:installed:1.26
xbitmaps:20120721:installed:1.1.1
evieext:20120721:installed:1.1.0
xproxymanagementprotocol:20120721:installed:1.0.3
bdftopcf:20120721:installed:1.0.3
mkfontscale:20120721:installed:1.0.8
xfs:20120721:installed:1.1.0
smgl-foma:20120721:installed:0.5.1
font-cursor-misc:20120721:installed:1.0.3
font-util:20120721:installed:1.2.0
font-alias:20120721:installed:1.0.3
dbus:20120721:installed:1.6.2
linux-pam:20120721:installed:1.1.5
coreutils:20120721:installed:8.17
xfsprogs:20120721:installed:3.1.8
curl:20120721:installed:7.26.0
cscope:20120721:installed:15.7a
libssh2:20120721:installed:1.4.2
bash:20120721:installed:4.2
c-ares:20120721:installed:1.9.1
man:20120721:installed:1.6g
vim:20120721:installed:7.3
ifupdown:20120721:installed:0.6.10
net-tools:20120721:installed:1.60
smgl-setup:20120721:installed:0.2
xz-utils:20120721:installed:5.0.4
libcroco:20120721:installed:0.6.5
libcap:20120721:installed:2.22
less:20120721:installed:444
init.d:20120721:installed:2.2.13
castfs:20120721:installed:0.6.1
librpcsecgss:20120721:installed:0.17
libnfsidmap:20120721:installed:0.20
elfutils:20120721:installed:0.152
autoconf:20120721:installed:2.69
automake:20120721:installed:1.12.2
libxcb:20120721:installed:1.7
libx11:20120721:installed:1.4.2
libxrender:20120721:installed:0.9.6
libxext:20120721:installed:1.2.0
libxt:20120721:installed:1.1.1
libxfixes:20120721:installed:5.0
nano:20120721:installed:2.2.6
hdparm:20120721:installed:9.39
libxres:20120721:installed:1.0.5
libxpm:20120721:installed:3.5.9
libxmu:20120721:installed:1.1.0
libxi:20120721:installed:1.4.2
libxrandr:20120721:installed:1.3.1
libxscrnsaver:20120721:installed:1.2.1
libxtst:20120721:installed:1.2.0
libxv:20120721:installed:1.0.6
libxvmc:20120721:installed:1.0.6
perl-error:20120721:installed:0.17018
procps:20120721:installed:3.2.8
ncurses:20120721:installed:5.9
rtmpdump:20120721:installed:2.4
libsemanage:20120721:installed:1.10.3
shadow:20120721:installed:4.1.5.1
fuse:20120721:installed:2.9.0
rsync:20120721:installed:3.0.9
netselect:20120721:installed:0.3
nfs-utils:20120721:installed:1.1.6
libgssglue:20120721:installed:0.4
libxdamage:20120721:installed:1.1.3
libxxf86vm:20120721:installed:1.1.1
tiff:20120721:installed:4.0.2
libxft:20120721:installed:2.2.0
libxcursor:20120721:installed:1.1.11
libxinerama:20120721:installed:1.1.1
libxcomposite:20120721:installed:0.4.3
gtk+:20120721:installed:1.2.10
xmms:20120722:installed:1.2.11
flac:20120722:installed:1.2.1
libsndfile:20120722:installed:1.0.25
libxaw:20120722:installed:1.0.9
libxkbfile:20120722:installed:1.0.7
libxkbui:20120722:installed:1.0.2
libxxf86misc:20120722:installed:1.0.3
xorg-libs:20120722:installed:7.1
libsamplerate:20120722:installed:0.1.8
gd:20120722:installed:2.0.36RC1
swig:20120722:installed:2.0.7
libxxf86dga:20120722:installed:1.1.2
sdl:20120722:installed:1.2.15
tk:20120722:installed:8.5.11
lesstif:20120722:installed:0.95.2
xpdf:20120722:installed:3.03
libxfontcache:20120722:installed:1.0.5
xinit:20120722:installed:1.3.1
bitmap:20120722:installed:1.0.5
xhost:20120722:installed:1.0.4
xauth:20120722:installed:1.0.5
rgb:20120722:installed:1.0.4
libxp:20120722:installed:1.0.1
mesalib:20120722:installed:7.9.2
freeglut:20120722:installed:2.8.0
git:20120722:installed:1.7.11.2
dbi:20120722:installed:1.622
dbd-sqlite:20120722:installed:1.31
mime-base64:20120722:installed:3.09
digest-md5:20120722:installed:2.40
md5:20120722:installed:2.03
digest-sha1:20120722:installed:2.13
digest-hmac:20120722:installed:1.01
authen-sasl:20120722:installed:2.10
net-ssleay:20120722:installed:1.42
io-socket-ssl:20120722:installed:1.54
net-smtp-ssl:20120722:installed:1.01
cairo:20120722:installed:1.12.2
cups:20120722:installed:1.5.3
jasper:20120722:installed:1.900.1
python:20120722:installed:2.7.3
pycairo:20120722:installed:1.10.0
glib2:20120722:installed:2.33.6
gobject-introspection:20120722:installed:1.33.4
dbus-glib:20120722:installed:0.100
dbus-python:20120722:installed:1.1.1
policykit:20120722:installed:0.105
consolekit:20120722:installed:0.4.5
udev:20120722:installed:175
gdk-pixbuf2:20120722:installed:2.26.1
atk:20120722:installed:2.4.0
pango:20120722:installed:1.30.1
gtk+2:20120722:held:2.24.10
ghostscript:20120722:installed:9.05
libgdiplus:20120722:installed:2.10
devil:20120722:installed:1.7.8
gtkglext:20120722:installed:1.2.0
psutils:20120722:installed:p17
gtk+3:20120722:installed:3.4.4
texlive:20120722:installed:20110705
ps2eps:20120722:installed:1.64
dvipdfmx:20120722:installed:20090708
dvipng:20120722:installed:1.14
lcdf-typetools:20120722:installed:2.79
xkbcomp:20120722:installed:1.2.1
xkeyboard-config:20120722:installed:2.0
setxkbmap:20120722:installed:1.1.0
pygobject:20120722:installed:2.28.6
pkgconfig:20120722:installed:0.26
libffi:20120722:installed:3.0.11
smgl-fhs:20120722:installed:2.2.2
bzip2:20120722:installed:1.0.6
zlib:20120722:installed:1.2.7
util-macros:20120722:installed:1.13.0
zip:20120722:installed:3.0
libart_lgpl:20120722:installed:2.3.21
xtrans:20120722:installed:1.2.6
gdbm:20120722:installed:1.10
tcl:20120722:installed:8.5.11
freetype2:20120722:installed:2.4.10
expat:20120722:installed:2.1.0
perl:20120722:installed:5.16.0
xml-parser-expat:20120722:installed:2.41
valgrind:20120722:installed:3.7.0
libpthread-stubs:20120722:installed:0.2
libgpg-error:20120722:installed:1.10
libpng:20120722:installed:1.2.50
ghostscript-fonts-std:20120722:installed:8.11
jpeg:20120722:installed:8d
libpciaccess:20120722:installed:0.12.1
gccmakedep:20120722:installed:1.0.2
xorg-cf-files:20120722:installed:1.0.4
popt:20120722:installed:1.16
intltool:20120722:installed:0.50.2
giflib:20120722:installed:4.1.6
libidn:20120722:installed:1.25
libpaper:20120722:installed:1.1.24
t1lib:20120722:installed:5.1.2


weird-cast.png - snapshot of system status (298 kB) Tommy Boatman, 07/21/2012 10:22 pm


Related issues

duplicates Sorcery - Support #416: cast -O and -R are dreadfully slow Closed 07/21/2012

History

Updated by Jaka Kranjc over 1 year ago

Why did you add -R? That causes it to recurse the whole tree above it (you probably wanted -B), which is far from necessary and the reason for the long computation times. There's a feature request open for limiting it with a specified level (1 would be enough here). And another one for speeding up libhash (ideally we'd switch to associative arrays, but you can't export any arrays in bash yet).

  • Status changed from New to Feedback

Updated by Jaka Kranjc over 1 year ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF