About News Download Docs Forum Bugs Contact

Forum

Information

Tools

Resources

installing particular version of software

Submitted by santjagos 14 Dec, 2021 23:22 #

Hi. Is it possible to install Sourcemage GNU/Linux with specific (particular) version of software? Let's say I want to install legacy nvidia drivers (nvidia-legacy-304xx) and to be able to do that I need to install old xorg package. You get the idea, right? Am I able to do that in Sourcemage? Thank you for your advises.

--

PerĂº

Submitted by stealth 17 Dec, 2021 23:19 #

Not easily I'd say, but it depends on the case.

Spells are very easy to hack, and as long as drivers are compatible with this specific xorg version, there shouldn't be any issues.

You'll have to use a custom spell though: checkout the commit from grimoire.git when the driver was at specific version and copy it to a local grimoire. If there were not a lot of spell customizations between two versions (like dependencies that will be needed to be tweaked), it should be fine.

I personally have a lot of new/old spells in the mix.

 
Register or login to post a reply.