System: host: "archiso-5.7.6-arch1-1", chroot: "smgl-test-0.63-20190513", grimoire "0.63-test"

Synopsis: When casting spell "linux" without loadable modules support, it exits with the following error:

The present kernel configuration has modules disabled.
Type 'make config' and enable loadable module support.
Then build a kernel with module support enabled.

make: *** [Makefile:1383: modules] Error 1

How to reproduce: 'cast -r linux' with "CONFIG_MODULES=n".

How to fix: In 'BUILD': check for "CONFIG_MODULES=y" before calling 'make modules'. Diff:

<   eval make $EXTRA_MAKE_OPTIONS modules &&
>   if grep -q 'CONFIG_MODULES=y' ./.config ; then
>     eval make $EXTRA_MAKE_OPTIONS modules
>   fi &&
Edited 28 Jun, 2021 03:41